WooCommerce und Hosteurope: oauth_timestamp fehlt

Falls dein Webspace bei Hosteurope ist und du WooCommerce verwendest, kann es zu dieser Fehlermeldung kommen.

Das Problem ist derzeit übrigens nur bei Hosteurope bekannt und kann durch Änderung am SourceCode umgangen werden. Mit jedem Woo-Update muss diese Zeile wieder eingefügt werden.

Hier die Fehlermeldung in unserem WordPress-Plugin:

Nicht verbunden (Error: Parameter oauth_timestamp fehlt [woocommerce_api_authentication_error])

Du musst folgende Funktion in der Datei “WooCommerce -> api -> legacy -> v2 -> class-wc-api-authentication.php” ändern (siehe Hervorhebung):

Achtung: Diese Änderung ist bei jedem Update von WooCommerce zu machen und ist unsupported!

 

Hat mir nicht geholfen (0)

2 Gedanken zu “WooCommerce und Hosteurope: oauth_timestamp fehlt

  1. Hat mir (leider) geholfen. Leider weil, ich ganz sicher vergessen werden nach dem update dran zu denken. Aber top das es wieder läuft!

    Gefällt mir (0)
    Gefällt mir nicht (0)
    • Kann natürlich vorkommen. Falls du es vergessen solltest, siehst du aber einfach nur Fehler im AT-Produkt. Beim nächsten Durchlauf wird das Produkt dann wieder aktualisiert. Sollte also keine Probleme machen 😉

      Gefällt mir (0)
      Gefällt mir nicht (0)

Schreibe einen Kommentar